Qlik Cloud® – Qlik Cloud & Talend Cloud – AWS – US East (N. Virginia)

Incident Report for Qlik Cloud Status

Postmortem

Root Cause Analysis: 

On October 20th, 2025, starting at approximately 06:48 UTC customers began experiencing issues across Qlik Cloud and Talend Cloud due to an AWS outage in its us-east-1 region. 

Customers in Qlik Cloud – AWS – US East (N. Virginia), may have experienced login failures, difficulty opening apps, or issues with reload, reporting, prediction and automation functionalities. At approximately 09:41 UTC, when AWS applied its first mitigation, the major issues were resolved for most customers. However, due to continued AWS EC2 capacity shortages, we were unable to obtain sufficient resources to meet demand, which resulted in ongoing intermittent difficulty opening apps, or issues with reloads, reporting, prediction, and automation functionalities. 

Customers in Talend Cloud – AWS – US East (N. Virginia), might have experienced login issues, or issues with APIs or Talend Management Console (TMC) functionalities between 06:48 UTC and 09:41 UTC. 

The incident was caused by a region-wide outage in the AWS us-east-1 region. 

This was not a malicious event, and no customer data was compromised. 

Resolution and Remediations: 

Once AWS resolved its underlying infrastructure issues, Qlik platforms services recovered. 

To further enhance platform reliability and resiliency, Qlik is evaluating additional safeguards for partner related outages. We appreciate your patience and trust as we continue improving the resilience and reliability of our platform.

Posted Oct 30, 2025 - 16:14 UTC

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:55 UTC

Update

We continue to actively monitor the situation related to the earlier AWS outage. Several third-party service providers we depend on are still in the process of resolving residual issues stemming from that event. Our team remains engaged in monitoring and mitigation efforts to minimize any potential impact. We will provide additional updates as more information becomes available.
Posted Oct 21, 2025 - 02:05 UTC

Update

We’ve confirmed that the AWS ongoing issue is affecting our customers using Qlik services in Qlik Cloud or Talend Cloud. Our team continues to diligently work with AWS to mitigate the issue. We will keep you posted on any further updates.
Posted Oct 20, 2025 - 19:51 UTC

Update

AWS is currently deploying a patch and resolving the queued up global requests. Qlik will continue to monitor to declare our systems recovered when we see this occur.
Posted Oct 20, 2025 - 18:14 UTC

Update

AWS is still experiencing issues, which may affect your ability to open Qlik Cloud apps. We recommend retrying to open the app, and we will keep you updated with any further information.
Posted Oct 20, 2025 - 14:33 UTC

Update

AWS is still experiencing issues related to insufficient compute capacity errors, which may impact the ability to open your app. We suggest retrying to open the app, as systems are still recovering.
Posted Oct 20, 2025 - 11:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 09:41 UTC

Update

An AWS issue in the US-EAST-1 region is currently impacting our Cloud infrastructures.
We've identified that additional functionality is now affected as part of this ongoing issue — specifically: Talend Cloud TMC executions.
Check live status updates here: https://status.qlikcloud.com/
Posted Oct 20, 2025 - 08:25 UTC

Investigating

We’re investigating an issue affecting multiple areas of the platform, including: Login, API and open App with Qlik Cloud – US East (N. Virginia). Updates will be provided as new information becomes available during the resolution process. We apologize for any inconvenience and appreciate your patience.
Posted Oct 20, 2025 - 07:53 UTC