User login impact - Qlik Cloud

Incident Report for Qlik Cloud Status

Postmortem

Root Cause Analysis: 

On May 5, 2025, starting at approximately 15:33 UTC, customers, primarily in Qlik Cloud - US, may have experienced login failures, difficulty opening apps, browsing in the Hub, or issues with reload and automation functionality. 

This incident was triggered by a license validation check, which caused an unexpected increase in traffic. Upon reverting the change in the Qlik Cloud - US region, Qlik encountered a traffic-related untested race condition that significantly extended the duration of the impact and inhibited restoration of service. Other regions were briefly affected, but did not encounter this condition, resulting in rapid service restoration outside the U.S.  

This was not a malicious event, and no customer data was compromised. 

Resolution and Remediations: 

The resolution involved restoring the previous version of the service, recycling impacted nodes, and scaling up capacity to stabilize operations.

To further enhance platform resiliency, Qlik is expanding validation coverage and optimizing the handling of cross-cluster license checks. Deployment testing is also being refined to increase visibility into potential edge-case behaviors. We appreciate your patience and trust as we continue improving the resilience and reliability of our platform.

Posted May 12, 2025 - 16:07 UTC

Resolved

This incident has been resolved.

We apologize for the inconvenience and appreciate your patience.
Posted May 05, 2025 - 18:44 UTC

Monitoring

We have applied a fix, and the user login are being restored as we currently observe signs of improvement. We'll continue monitoring the results to ensure that Qlik Cloud is fully operational and functioning correctly.
Posted May 05, 2025 - 17:39 UTC

Update

We are continuing to investigate an issue affecting user logins to Qlik Cloud. Our engineering teams are actively exploring potential fixes and working to restore normal functionality.

We will share updates as more information becomes available. We appreciate your patience and apologize for the inconvenience.
Posted May 05, 2025 - 17:14 UTC

Investigating

We're investigating user login impact with Qlik Cloud and are diligently working to resolve the issue as soon as possible.
We'll provide new information as it becomes available while the issue is being addressed. We apologize for any inconvenience and appreciate your patience.
Posted May 05, 2025 - 16:40 UTC
This incident affected: Qlik Cloud – AWS – US East (N. Virginia).