Qlik Talend Cloud – “Azure US”

Incident Report for Qlik Cloud Status

Postmortem

Summary of Impact: 

On February 7th, 2026, starting at approximately 07:55 UTC and lasting until around 11:00 UTC, Qlik Talend Cloud® customers whose tenants are hosted in the AZURE - West US (California) region experienced platform unavailability and TMC execution failures due to an Azure service disruption in its West US region. 

Root Cause: 

Azure experienced a failure in its West US region due to an unexpected interruption to utility power at their datacenters, which caused a temporary loss of power to parts of the facility. Multiple Azure services in the region may have experienced intermittent unavailability, timeouts, or increased latency. This disruption impacted Qlik Talend Cloud, resulting in the observed platform unavailability and execution failures. 

Resolution and Remediation: 

Qlik Engineering and Operations teams immediately identified the connectivity loss and engaged with Azure Support to track the mitigation of the underlying failure. Once Azure stabilized the region's power systems and services, Qlik services automatically recovered. 

We apologize for any inconvenience this disruption may have caused to your operations.

Posted Feb 12, 2026 - 13:32 UTC

Resolved

This issue has been resolved. We apologise for the inconvenience and appreciate your patience.
Posted Feb 07, 2026 - 11:28 UTC

Monitoring

The issue has been fixed and the team is monitoring the results
Posted Feb 07, 2026 - 11:02 UTC

Update

We are still engaging at the highest level with our vendors to restore the service
Posted Feb 07, 2026 - 10:19 UTC

Identified

The issue has been identified at Azure level, and our team is actively working with our vendor on mitigation and implementing a fix.
Posted Feb 07, 2026 - 09:20 UTC

Investigating

We're investigating an issue affecting the Talend Management Console in Qlik Talend Cloud® – “Azure US” and are diligently working to resolve the issue as soon as possible. Updates will be provided as new information becomes available during the resolution process. We apologize for any inconvenience and appreciate your patience
Posted Feb 07, 2026 - 08:59 UTC
This incident affected: Talend Cloud - AZURE - West US (California).